Page Manager | *.php

#1

Hey there,
I tried to use the page manager with *.php-files, but it failed.
I can duplicate a site, but I’m not able to edit details or to publish.
Is it only working with *.html-files?
Thanks a lot
Matthias

#2

Sitecake and page manager as a part of Sitecake works the best with HTML files.
It also works with php files but with simple php files.

So if you have a simple php website, you should have no problem with page manager.

#3

Thank you, Nik.
I changed the programming of this page to pure html,
and then I could duplicate it and make changes at the details.

But I am not able to publish it.

Are there may-be any settings to change or something else?

#4

You have to make sure to have only one sc-nav section per page. If you have two or more different sc-nav sections Sitecake does not know which one to copy to other pages.

#5

Good morning and thanks,

I have one “sc-nav” section and I checked the permissions of the *.html and the folder in FTP.

Unfortunatly I already couldn’t publish the duplicated site.

#6

I can’t help you more without getting access to your cPanel. Please send details through the ticket.

#7

I’ve checked the code. CSS issue is not alowing menu to show.

Tip: When something is wrong with Sitecake editing, always hit F12 in the browser and delete all included CSS files just to see how pure HTML looks and works. In 90% of cases users hide things with CSS layout issues.

#8

Thanks and: hm, I don’t understand.

I don’t want to add this page to the menu and I didn’t try this.
I only want to duplicate it and set a link in the parent page using “copy url”.

Its right, the menu will be shown per click and via javascript + css,
but it is there (top: -390%) and it is active all the time and the menu-code is within / on this page.
I can hardly imagine that the problem is that the menu is not visible in the browser.

If I hit F12 in the browser and delete the css-file I find no error. The HTML is clean and I see everything one after another.

#9

I uploaded zipped version of your website to our A2hosing test server and everything worked. I am runnin out of ideas why it’s not working on your end.

If Sitecake log does not have errors, PHP version is okay, file permissions ok and all other things from the error 500 list I really do not know.

Last thing to try is to remove Sitecake, temp and backup folders and upload them again. In this way you will make sure that all Sitecake files are uploaded and that drafts from the temp folder are deleted.

#10

Thank you for your effort, Nik!

I want to send you the log-file with the entries from today, September 15.
There are listed some errors.
May-be you see what is wrong or mistakes I’ve may-be done.

I see I can’t send you the log-file from here. Is there another possibility to send the file?

#11

Reply to the original ticket please.