Page Manager Error after clicking Publish

#1

If I edit anything in PageManager, for example the meta description, or rename the page file, or even duplicate it and then hit Publish button it never finishes (shows loader on blue button) and the webinspector consol gives “unknown error” in “pagemanager.2.4.10.js”.

It also should be noted the actual operation I am trying to perform(rename, duplicate, meta change etc) is successful but sitecake stops working after that gives an error page (with blue wavy background).

This can be fixed by deleting the temp folder but it’s annoying.

any ideas? I can send the log file if needed as the problem is to recreate.

#2

This error occurs when you do not have same main nav on all pages. For example, you create main nav with Sitecake and then manually add a page with different main nav. Sitecake is confused which nav is the right one.

Make sure that sc-nav section is the same on all pages.

#3

Thanks for the quick reply, I checked that I don’t have an sc-nav at all. I’m just playing around a single div page with sc-content. I’ve also tried to test this on your demo template and same error occurs.

#4

Demo template is one pager, menu item links are just scrolling the page. It’s not suitable for page duplication.

Please create a ticket and send me your template so I can test it and reproducte the errors.

#5

Ok I’m not sure I’m clear enough with my issue.

Let’s break it down.

The error occurs in all cases, no matter if it’s a single page or multi page website with sc-nav in it.
A tested it with a simple index.html with a single div with sc-content class. Opened page manager, changed the “meta description” clicked publish and got the error. so it’s not related to sc-nav at all.
also, I might just want to duplicate a page and rename it for example index_de.html and use it as another language page. that does not work either. I mean it creates the file but the pagemanager publish button keeps spinning. and then if I refresh the page I get errors even though the file was created.

In short any operation in Page Manager leads to error.
I’m running this locally so I can post my log file here no probs. Also, requirements.php gives no errors.
Do you still want me to create a ticket?

Thanks

#6

I’ve opened the ticket as well…

#7

Anyway, as expected it was not caused by faulty markup or anything related to that.
It was caused by Debug variable that was set to True in config. Just needed to set it back to false.

Hope this helps someone in the future.

Bye.

#8

Thanks this helps a lot!