HTTP ERROR 500 from fresh installation


#1

Hello,

I got this error from a fresh installation. I just followed the installation guide:

  1. Upload Sitecake to my site.
  2. Visit mysite.com/sitecake/sitecake.php

And I got the error 500. Nothing in the log, just the error in the browser.

I also tried creating an index.html with the sc-content as suggested, but nothing change.

I found out a requirements.php file (sitecake/2.4.8/config/requirements.php) which says:

Basic server configuration needed for Sitecake to run is OK

Some additional data about my environment:

$ php -v

PHP 7.0.27-0+deb9u1 (cli) (built: Jan 5 2018 13:51:52) ( NTS )
Copyright © 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright © 1998-2017 Zend Technologies
with Zend OPcache v7.0.27-0+deb9u1, Copyright © 1999-2017, by Zend Technologies

$ dpkg -l|grep apache

ii apache2 2.4.25-3+deb9u3 amd64 Apache HTTP Server
ii apache2-bin 2.4.25-3+deb9u3 amd64 Apache HTTP Server (modules and other binary files)
ii apache2-data 2.4.25-3+deb9u3 all Apache HTTP Server (common files)
ii apache2-utils 2.4.25-3+deb9u3 amd64 Apache HTTP Server (utility programs for web servers)
ii libapache2-mod-php7.0 7.0.27-0+deb9u1 amd64 server-side, HTML-embedded scripting language (Apache 2 module)

I would appreciate some help here, also, I can’t share the credentials of my hosting (ssh, ftp or anything), If you need my proof of buying, just let me know.

Thanks,
Marco.


#2

Did you check sitecake log file? You can find it in one of subdirs of sitecake-temp dir in your site root directory.


#3

Thanks @predragleka, I was able to found the error and fix it.

It would be cool if you can add this info to your documentation.


#4

Hello @Marco,

How did you manage to fix it?
I am facing the same issue (apparently).

Thanks for your help


#5

Hi @Rom Check for sitecake.log file. You can send it by posting a ticket or in PM. Problem that Marco had maybe isn’t the same one you have. 500 error is general server error that is returned from server if anything goes wrong.


#6

Hello @predragleka,

Yes I tried to check the logs but it is not even generated because the page doesn’t start loading, as of I push enter the error is thrown…
I don’t know what to do as it works in local and going back to 2.4.8 on server make it work again.


#7

In my case, there were logs in the internal sitecake log dir (not in the server logs). And in my case was I was using the same index.html, which doesn’t have tags and the error was complaining about the missing tag.