Error when trying to save content

#1

Hello!

I’ve been developing a sitecake website locally and it’s been working absolutely perfect! However, when I upload it to the liveserver, I cannot save any changes anymore.
If I use the local filesystem option I get "#1 An error has occured while trying to publish the content. Forbidden" error, which from reading this forum seems to be connected to read/write permissions. I’ve tried change every files permissions to 777 and it still doesn’t seem to work.

When I then try to use the ftp filesystem adapter I’m met with this error “LogicException: Could not ensure that the directory /sitecake/logs is present and writable. in file [SITE]/sitecake/2.4.5/src/Sitecake/Log/Engine/FileLog.php on line (#93)” when trying to access /sitecake.php even though the logs directory is present and with permissions set to 777 as well, so now I’m not sure where to go from here. Ideally I would like the local filesystem option to work, but at this point I will be happy to just be able to save my changes.

Any ideas?

#2

Hi, can you send site url and sitecake password as PM to me so I can check it out?

#3

Hey! Yes, but I cannot figure out where to send a PM. I can find my messages, but not see anywhere I can create a new message?

#4

Just click on my avatar in this conversation and click blue ‘Message’ button

#6

I got a very simular error.
The in the logfiles the last entry is:
[2020-01-08 00:07:28] app.INFO: Matched route “{route}”. {“route”:“GET_”,“route_parameters”:{"_controller":"[object] (Closure: {})",“route":"GET”},“request_uri”:“https://www.myurl.net/sitecake/2.4.10/src/app.php/?action=alive&service=_session",“method”:"GET”} []

I allready changed the permissions of the folders to 755 and the files to 644. But its still not working.
Any ideas?